زمان‌بندی اعمال محدودیت‌های Target SDK برای توسعه‌دهندگان مایکت

منتشر شده در  ۷ خرداد ۱۳۹۸

همانطور که احتمالا می‌دانید، گوگل به‌زودی محدودیت‌هایی در Target SDK برنامه‌ها اعمال خواهد کرد. طبق برنامهٔ زمان‌بندی اعلام شده در بلاگ گوگل، از تاریخ ۱۰ مرداد ۱۳۹۸، نصب برنامه‌هایی که Target SDK پایین‌تر از ۲۶ دارند، در دستگاه‌های با اندروید بالاتر از ۸ ، از طرف سیستم‌عامل با هشدار امنیتی مواجه خواهند شد.
به همین دلیل مایکت برای جلوگیری از بروز این خطا برای کاربران و توسعه‌دهندگان، در نظر دارد که توسعه‌دهندگان را به به‌روزرسانی Target SDK برنامه‌های خود (به نسخهٔ 26 و بالاتر) سوق دهد.
از این رو زمان‌بندی اعمال محدودیت‌های Target SDK برای توسعه‌دهندگان مایکت به صورت زیر خواهد بود:
۱۸ خرداد: محدودیت انتشار برنامه جدید با Target SDK پایین‌تر از ۲۶
۱ مرداد: محدودیت انتشار به‌روزرسانی جدید با Target SDK پایین‌تر از ۲۶
۹ مرداد: محدودیت امکان نصب و به‌روزرسانی برنامه‌های با Target SDK پایین‌تر از ۲۶ روی دستگاه‌های اندروید ۸ و بالاتر در مایکت

توجه کنید که از تاریخ ۹ مرداد ۱۳۹۸ برنامه‌هایی که Target SDK پایین‌تر از ۲۶ دارند، برای کاربران با دستگاه‌های بالاتر از اندروید ۸، ناسازگار خواهد بود. بنابراین با توجه به سرعت رشد نسخه‌های جدید اندروید و محدودیت‌های فعلی Google Play Protect، پیشنهاد می‌شود که هرچه سریع‌تر اقدام به به‌روزرسانی Target SDK نمایید.

در نظر داشته باشید که برای به‌روزرسانی Target SDK، حتما «مستند نیازمندی‌های مهاجرت به نسخه‌های جدید Target SDK» را بخوانید.

Was this article helpful?
Dislike 0
قبلی: عذر خواهی از توسعه دهندگان مایکت بابت تاخیر در تصفیه حساب آبان ماه
بعدی: دسته بندی ویژه کودکان در مایکت